Your browser does not support JavaScript!
[1070827]【漏洞預警】Apache Struts 2.3.X與2.5.X系列版本存在允許攻擊者遠端執行任意程式碼之漏洞
影響等級:高
發現時間:2018-08-27
原標題名稱:【漏洞預警】Apache Struts 2.3.X與2.5.X系列版本存在允許攻擊者遠端執行任意程式碼之漏洞(CVE-2018-11776),請儘速確認並進行修正

轉發國家資安資訊分享與分析中心 資安訊息警訊 NISAC-ANA-201808-0186。
Apache Struts 2是一個開放原始碼的Java EE網路應用程式的Web應用框架。 該漏洞主要是在Apache Struts 2.3.X與2.5.X系列版本中,以下兩種情況皆可能導致攻擊者可遠端執行任意程式碼:
1.未針對xml設定檔中的result元素設定命名空間(namespace)屬性,且上層action元件亦未設定或使用萬用字元設定命名空間(namespace)屬性。
2.使用未設定value與action的url標籤,且上層action元件亦未設定或使用萬用字元設定命名空間(namespace)屬性。

影響平台-
Apache Struts 2.3至2.3.34(含)的版本 Apache Struts 2.5至2.5.16(含)的版本

建議措施-
1.請確認網站主機是否使用Apache Struts 2的Web應用框架,若有使用則可再透過網站主機目錄中的「WEB-INF\lib\」資料夾內的Struts2.jar檔確認當前使用的版本。
2.如所使用的Apache Struts為上述受影響之版本,則請更新官方網頁(https://struts.apache.org/download.cgi)或官方Github所釋出最新之Apache Struts 2.3.35或2.5.17的版本。

參考資料-
1.https://cwiki.apache.org/confluence/display/WW/S2-057
2.https://struts.apache.org/download.cgi
3.https://thehackernews.com/2018/08/apache-struts-vulnerability.html?m=1
內容更新 : 2018-10-17
瀏覽數  
將此文章推薦給親友
請輸入此驗證碼
網站連結